Changing the hostname of Portal2 server


I was told today that the hostname of the server where I have installed Flow Server and Portal 2 has to be changed from NovaCuraPortal to NovaCuraPortal.local, because in some VPN connections NovaCuraPortal is not solved by DNS.

I guess that can be done “blindingly” by replacing “NovaCuraPortal” by “NovaCuraPortal.local” in every file that looks like being related with configuration. Am I right? If not, how can I do the change of the FQDN?



i think you can change it in the IIS binding

But Portal is very specific to hostnames so you would need to change it in these 2 files also:

Hope this helps!



It is not as easy as 1-2-3 unfortunately to just change the host name. It should work as you say to try to find all related files, but if you are using subscribed workflows etc there might be more to it.

The best option is usually to assign a DNS name initially (like and use that both internally and externally (set up an internal DNS zone).

So if they ever want to expose the flow server externally it is better to think about it already now.If https is used there are also certificates to consider.

So I cannot promise, but I think you would be able to get it up and running by changing the web.configs and settings.json files. Subscriptions might break.


Thank you @ivstde and @OlaCarlander . As soon as I have all the DNS stuff OK (which is to be done not by me), I will try doing it in the DEV portal and then I will inform of the result here.

I tried just now to change the hostname of the development portal from siglxport to and the result was disastrous.

Steps taken:

  1. I began by making a copy of the app and data directories, hoping that reversing any changes was just a matter of putting again the backup copies.
  2. Replaced siglxport by in the files whose names look like having to do with “configuration”. Since the sufix of the domain is DEV, initially I was redirected to https, which doesn’t exist, so I configured my Firefox browser to use http for such domains, but I wasn’t even able to login, as there was an error saying that the page didn’t exist or the server was not found (the errors ar always of these two kinds, I don’t remember when appears one or the other.
  3. I restarted IIS several times, cleared the cache and restart the browser several times and also put in the bindings of the website (which is the default website) all the variations that should work (with or without hostname and/or IP) I remember besides what I had (everything coming by http in port 80 pointing to the Novacura applications).
  4. After that, I replaced siglxport by in every file with name settings*, *.json and *.ini. The result was the same.
  5. In dispair I did the replacement in every file. Again, with no success.
  6. Finally I put the copies I did did in the first steps and now I can’t login. That is not the only strange thing because initially sometimes the login page appeared briefly before the other messages appeared, but now, after sometimes appearing for a couple of miliseconds a page that looks like having just a few words I am presented with a blank page when I go to the root of the portal (http://siglxport/Novacura.Flow.Client.Portal2/); then, after several tens seconds, appears an error 500 with a popup with “Error occurred / Flow Server: [object Object]”.
  7. I forgot to try to login in Flow Studio in the steps before, but now I can’t.

Any hints, not only to change the hostname, but also how can I put the portal and Flow Server working again without having to make a new instalation, which would require me to import every portlet and Studio stuff manually?

Thank you.

Wow, really sorry to hear that…

No idea how it went so wrong.
But if you backed up the 2 folders (data and installation folder/one with the server instance name) then you should be ok. Everything should be in there, if you just restore that and IIS to the previous state it should work again.

But you say your Flow Server doesnt work (cant be reached from studio) after restoring files:
-What does your IIS look like?
-Can you create one binding with no host name and reach the server by localhost?

Thank you for your reply @ivstde

After reading your post I went to http://localhost/Novacura.Flow.Server, which is the same as http://localhost/Novacura.Flow.Server and the page showed be an error related to the …\Novacura Flow\Data\Executions\db being read-only.

I went see what was happening and the IIS windows users (I never remember which one is needed…) had no write permissions on the Novacura Flow directories branch. I had forgotten that I had applied the permissions only to “Novacura Flow” directory so the permissions of the copy inheritated the permissions of the father directory…

Well, the problem solved of putting back the portal and Flow Server back in the original hostname is solved! Thank you!

But I still don’t know how to change the hostname… I think I will try again by changing only the two files you pointed.


the iis-user to set folder permossion for is iisapppool\the name of the app pool. Very many “p”

I would also recommend stopping IIS before making changes, and then starting it when done.

But that said, you should not have to set the above setting after changing some ini and json files. Maybe this was due to that you moved entire folders?

I think I would start with the flow server, making sure that works ok, and then move my way out towards the different clients.

Maybe the license has to be updated as well after a host name change



I was able to change the hostnames in the PROD and DEV environments. Thank you very much, @OlaCarlander and @ivstde.

What I did was replacing the old hostname by the new hostname (in my case a FQDN) in the following files. Maybe there is one or two missing in this list, so for caution, look for every file with the following patterns: *.ini setting*.json *settings.json *.config *.asax *.asa

I replaced also http:// by https:// in one of the portals that I put with https. Another thing that I needed to do was replacing localhost by the new hostname in those files; perhaps that is not needed in every case or when you don’t change the site from HTTP to HTTPS or vice.versa, but anyway, all seems ok with those replacements.

List of files:

  • AppDir\Portal2020\Services\Novacura.Flow.Client.Portal2\assets\settings.json
  • AppDir\Portal2020\Services\Novacura.Flow.Client.Portal2\assets\dev.settings.json
  • AppDir\Portal2020\Services\Novacura.Flow.Client.Portal2.Session.Service\Web.config
  • AppDir\Server\web.config
  • AppDir\Portal2020\Services\Novacura.Flow.Client.Portal2.Web.Api\appsettings.json
  • AppDir\Portal\Web.config

where AppDir is the directory where Novacura is installed (C:\Novacura\Novacura Flow in my case).

I didn’t change any thing in the Data directory.

I am not 100% sure that everything is working fine because I didn’t do comprehensive tests. I will update this thread if I detect any problem.

There is a curious detail, which is that I can’t login in Flow Studio with https, although it works with http.