"WorkflowStepInvalid" error after period of inactivity

Hi there,

We’ve recently upgraded Flow Classic from 6.14.8 to 6.15.9 and since the upgrade the users are complaining of getting this error if they have left a Flow open and go back to it after a period and try to proceed to the next screen etc:
Error after inactivity

They did not get this error previously and now need to quit out of the flow and go back in.

For example in this screen they were used to keeping the Flow open and hitting refresh periodically:

Is this a change in 6.15 that it is disconnecting the user’s session? Is there a setting somewhere?

many thanks,


Hi Gail, Will you be able to share the contents of the “details” dropdown shown on the pop up please.

Hi Amri,

It just says ‘Source: Flow Server’


The error appeared today after only leaving the Flow idle for around 5 minutes so I can see why our users are getting frustrated.

Many thanks,

Im not aware any timeouts that have been rolled out with 6.15 but I’d suggest you to try the same in our New Web client since the old web client is outdated. Please let me know if the issue persists in the new client. Client - Flow Classic (novacuraflow.com)

Thanks Amri, is there something I need to do to use the new Web client? as I just get an ‘Unable to connect to the server’ error.
I get this even if I try on the server itself.

Also, I’m sure that the tablets have all been updated to the latest version of the App but they still get the “WorkflowStepInvalid” error.

Many thanks,


Hi Gail, Can you try with the server PIN code as well?
If you continue to get the error I’d suggest you raise this as a ticket via Novacura Customer Services - Jira Service Management (atlassian.net) so the support team could take a better look at it.


Thanks Amir - I had tried with the server PIN too, so I’ll raise a ticket.

Thanks for your help,
Kind regards,