# Server call error

**URL:** https://forum.novacura.com/t/server-call-error/709
**Category:** Flow Classic
**Created:** [June 24, 2024, 9:03pm UTC](https://forum.novacura.com/t/server-call-error/709 "2024-06-24T21:03:57Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![Keyhole](https://avatars.discourse-cdn.com/v4/letter/k/7C9FD7/32.png) [@Keyhole](https://forum.novacura.com/u/Keyhole)
#### Post date: [June 24, 2024, 9:03pm UTC](https://forum.novacura.com/t/server-call-error/709/1 "2024-06-24T21:03:57Z")

</div>

Hello all. We are currently receiving an error when requesting all of our vessels from an API. When we request just a single vessel using the same API, it works. Does anyone know of a setting/parameter within Novacura that would prevent us from receiving a large amount of data in a call?  
 ![image](https://europe1.discourse-cdn.com/flex013/uploads/novacuratalk/original/1X/adf685df50e86c5328f7ce7278ab2a18e839774b.png)

---

<div class="post-metadata">

### Author: ![daniel](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.novacura.com/daniel/32/708_2.png) [@daniel](https://forum.novacura.com/u/daniel)
#### Post date: [June 24, 2024, 9:18pm UTC](https://forum.novacura.com/t/server-call-error/709/2 "2024-06-24T21:18:41Z")

</div>

Just in general, if you are requesting one item, in this case vessel, you can use the “GET” type. For lot’s of data, normally API endpoints switch to the “POST” type. There shouldn’t be a Novacura flag/setting/parameter that limits the amount of data (unless it is over let’s say a default of 50Mb - and if your data is just txt, it’d be very hard to hit this limit).

---

<div class="post-metadata">

### Author: ![Keyhole](https://avatars.discourse-cdn.com/v4/letter/k/7C9FD7/32.png) [@Keyhole](https://forum.novacura.com/u/Keyhole)
#### Post date: [June 24, 2024, 9:24pm UTC](https://forum.novacura.com/t/server-call-error/709/3 "2024-06-24T21:24:51Z")

</div>

We can make the same call in PostMan and using a Shell script and even though it takes about 4-5 minutes to get results, we get results. In Novacura is just throws the error I posted above. Do you or anyone know what the Novacura error means? Is there a list of errors that Novacura has listed somewhere so I know where to look?

---

<div class="post-metadata">

### Author: ![daniel](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.novacura.com/daniel/32/708_2.png) [@daniel](https://forum.novacura.com/u/daniel)
#### Post date: [June 24, 2024, 9:31pm UTC](https://forum.novacura.com/t/server-call-error/709/4 "2024-06-24T21:31:39Z")

</div>

What version of Novacura Serever are you running?

In general, tasks will timeout around 60s. You would have to chunk the data to stay below that 60s marker. There are also some IIS hacks to implement to get the longer timeouts. Follow this “advice” for longer run times:

1. Upgrade to \>6.14 (I recommend 6.15 as 6.14 and lower are no longer supported)
2. Adjust the following IIS advanced settings for the Flow Server app pool:

- Start Mode = AlwaysRunning
- ProcessModel → Idle Timeout (minutes) = 0
- Recycling → Regular Time Interval (minutes) = 0
- Recycling → Specific Times = Add one or two times a day when no workflows are scheduled and flow server has less traffic.

1. Adjust advanced settings for the Server App (under your site):

- Preload Enabled = True (if this options isn’t available you need to install a IIS feature called _Application Initialization Module_

1. Open web.config for flow server and add the following in the system.webServer section if it doesn’t exist:

```auto
<applicationInitialization doAppInitAfterRestart="true" skipManagedModules="false">

<add initializationPage="/" />

</applicationInitialization>

```

---

<div class="post-metadata">

### Author: ![Keyhole](https://avatars.discourse-cdn.com/v4/letter/k/7C9FD7/32.png) [@Keyhole](https://forum.novacura.com/u/Keyhole)
#### Post date: [June 24, 2024, 10:01pm UTC](https://forum.novacura.com/t/server-call-error/709/5 "2024-06-24T22:01:03Z")

</div>

We are on 6.14.9.16

i will try the settings you mentioned.

Here’s the error in the error.log:

2024-06-24T14:47:39.5610850-07:00: One or more errors occurred. at at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)  
at System.Threading.Tasks.Task`1.GetResultCore(Boolean waitCompletionNotification) at System.Threading.Tasks.Task`1.get\_Result()  
at NovaCura.Flow.Connector.Rest.RestApi.Get(RestRequest request)  
at DynamicModule.ns.Wrapped\_IRestApi\_21a7a6598d1643259ad560610b7eb637.\<Get\_DelegateImplementation\>\_\_0(IMethodInvocation inputs, GetNextInterceptionBehaviorDelegate getNext)  
InnerException: A task was canceled. at  
at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)  
at System.Threading.Tasks.Task`1.GetResultCore(Boolean waitCompletionNotification) at System.Threading.Tasks.Task`1.get\_Result()  
at NovaCura.Flow.Connector.Rest.RestApi.Get(RestRequest request)  
at DynamicModule.ns.Wrapped\_IRestApi\_21a7a6598d1643259ad560610b7eb637.\<Get\_DelegateImplementation\>\_\_0(IMethodInvocation inputs, GetNextInterceptionBehaviorDelegate getNext)

---

<div class="post-metadata">

### Author: ![Keyhole](https://avatars.discourse-cdn.com/v4/letter/k/7C9FD7/32.png) [@Keyhole](https://forum.novacura.com/u/Keyhole)
#### Post date: [June 25, 2024, 5:20pm UTC](https://forum.novacura.com/t/server-call-error/709/6 "2024-06-25T17:20:43Z")

</div>

Our server had these settings currently.
